wiki:NBMA_OSPF_STAROS_ISP_DEMO

Router A

interface wpcm0
ip ospf network non-broadcast
!
router ospf
ospf router-id 0.0.0.1
redistribute kernel
redistribute connected
redistribute rip
redistribute bgp
network 192.168.0.0/24 area 0
network 192.168.20.0/24 area 0
redistribute static
network 192.168.0.1/24

Router B

interface wpcm0
ip ospf network non-broadcast
!
router ospf
ospf router-id 0.0.0.2
redistribute kernel
redistribute connected
redistribute rip
redistribute bgp
network 10.0.1.0/24 area 0
network 192.168.0.0/24 area 0
neighbor 10.0.1.253

Router C

interface wpcm0
ip ospf network non-broadcast
!
interface wpcm1
ip ospf network non-broadcast
!
router ospf
ospf router-id 0.0.0.3
redistribute kernel
redistribute connected
redistribute rip
redistribute bgp
network 10.0.1.0/24 area 0
network 10.0.2.0/24 area 0
network 10.0.100.0/24 area 0
neighbor 10.0.1.254
neighbor 10.0.2.253

grimoire

http://upload.wikimedia.org/wikipedia/commons/thumb/a/ad/Agasse_Quagga.jpg/220px-Agasse_Quagga.jpg

  • StarOS Requires the Flag for NBMA Networks

I have learned "the hard way" that OSPF won't broadcast via wireless (at least on Zebra) so I have to make the interface a non-broadcast network and specify my wireless neighbour routers.

ip ospf network non-broadcast
!
  • The only real limiting factor that may compel major ISPs to select IS-IS over OSPF is if they have a network with more than 850 routers.

rfc

lesson for Dale

hardcore primer

  • OSPF is an interior gateway protocol that routes IP packets solely within an autonomous system (routing domain).
  • It gathers link-state information from available routers and constructs a topology of the network.
  • The topology determines the routing table presented to the Internet Layer which makes routing decisions based solely on the destination IP address found in IP packets.
  • OSPF was designed to support VLSM or CIDR addressing models.
  • OSPF detects changes in the topology, such as link failures, and converges on a new loop-free routing structure within seconds.
  • It computes the shortest path tree for each route method based on the Dijkstra's Algorithm, a shortest path first algorithm.
  • The OSPF routing policies to construct a route table are governed by link cost factors (external metrics) associated with each routing interface.
  • An OSPF network may be structured, or subdivided, into routing areas to simplify administration and optimize traffic and resource utilization.
  • Each additional area must have a direct or virtual connection to the backbone OSPF area.
  • Such connections are maintained by an interconnecting router, known as area border router (ABR).
  • OSPF does not use a TCP/IP transport protocol (UDP, TCP), but is encapsulated directly in IP datagrams with protocol number 89.
  • This is in contrast to other routing protocols, such as the Routing Information Protocol (RIP), or the Border Gateway Protocol (BGP). OSPF handles its own error detection and correction functions.
  • For non-broadcast networks special provisions for configuration facilitate neighbor discovery.
  • OSPF multicast IP packets never traverse IP routers (never traverse Broadcast Domains), they never travel more than one hop.
  • OSPF reserves the multicast addresses 224.0.0.5 for IPv4 or FF02::5 for IPv6 (all SPF/link state routers, also known as AllSPFRouters) and 224.0.0.6 for IPv4 or FF02::6 for IPv6 (all Designated Routers, AllDRouters), as specified in RFC 2328[3] and RFC 5340.[4]
  • For routing multicast IP traffic, OSPF supports the Multicast Open Shortest Path First protocol (MOSPF) as defined in RFC 1584.[5] Cisco does not include MOSPF in their OSPF implementations. PIM (Protocol Independent Multicast) in conjunction with OSPF or other IGPs, (Interior Gateway Protocol), is widely deployed.
  • The OSPF protocol, when running on IPv4, can operate securely between routers, optionally using a variety of authentication methods to allow only trusted routers to participate in routing. OSPFv3, running on IPv6, no longer supports protocol-internal authentication. Instead, it relies on IPv6 protocol security (IPsec).
  • OSPF version 3 introduces modifications to the IPv4 implementation of the protocol.[2] Except for virtual links, all neighbor exchanges use IPv6 link-local addressing exclusively. The IPv6 protocol runs per link, rather than based on the subnet. All IP prefix information has been removed from the link-state advertisements and from the Hello discovery packet making OSPFv3 essentially protocol-independent. Despite the expanded IP addressing to 128-bits in IPv6, area and router Identifications are still based on 32-bit values.

area types

Backbone Area forms the core of an OSPF network. All other areas are connected to it, and inter-area routing happens via routers connected to the backbone area and to their own associated areas. It is the logical and physical structure for the OSPF domain and is attached to all nonzero areas in the OSPF domain.

Stub Area is an area which does not receive route advertisements external to the autonomous system and routing from within the area is based entirely on a default route. This is achieved by an ABR deleting type 4,5 link-state announcements from internal routers.

Not-so-stubby areas import autonomous system external routes and send them to other areas, but still cannot receive AS-external routes from other systems.

router types

area border router is a router that connects one more areas to the main backbone of the network. It is considered a member of all areas it is connected to. An ABR keeps multiple copies of the link-state database in memory, one for each to which that router is connected.

autonomous system boundary router is a router that is connected to more than one routing protocol and that exchanges routing information with routers and protocols. ASBRs typically also run a BGP protocol or use static routes, or both. An ASBR is used to distribute routes received from other, external ASs throughout its own autonomous system.

internal router An internal router is a router that has OSPF neighbor relationships with interfaces in the same area. An internal router has all its interfaces in a single area

Designated Router is the router interface elected among all routers on a particular multi-access network segment, generally assumed to be broadcast multi-access. Do not confuse the designated router as a router type.

Last modified 6 years ago Last modified on 01/27/14 11:13:02