Changes between Version 34 and Version 35 of AWIKIServer


Ignore:
Timestamp:
08/31/15 19:43:05 (4 years ago)
Author:
admin
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • AWIKIServer

    v34 v35  
    158158 * npm install -- installs dependencies not found in debian. they need audited and packaged.
    159159
    160 == Installing ==
    161  * cd /var/lib/mediawiki/extensions
    162  * sudo git clone -b REL1_25 https://gerrit.wikimedia.org/r/p/mediawiki/extensions/VisualEditor.git
    163  * cd VisualEditor
    164  * sudo git submodule update --init
    165  * add the following to /etc/mediawiki/LocalSettings.php to enable the Visual Editor:
    166 {{{
    167 
     160== Installing VisualEditor ==
     161 * {{{ cd /var/lib/mediawiki/extensions }}}
     162 * {{{ sudo git clone -b REL1_25 https://gerrit.wikimedia.org/r/p/mediawiki/extensions/VisualEditor.git }}}
     163 * {{{ cd VisualEditor }}}
     164 * {{{ sudo git submodule update --init }}}
     165 * Add the following to {{{/etc/mediawiki/LocalSettings.php}}} to enable the Visual Editor:
     166
     167{{{
    168168require_once "$IP/extensions/VisualEditor/VisualEditor.php";
    169169
     
    175175
    176176== Configuring ==
    177  * Add the following to /etc/mediawiki/LocalSettings.php:
     177 * Add the following to {{{/etc/mediawiki/LocalSettings.php}}}:
     178
    178179{{{
    179180// Enable the visual editor by default for newly created users.
     
    189190= Other Extensions =
    190191== ParserFunctions ==
    191 Add the following to /etc/mediawiki/LocalSettings.php:
     192Add the following to {{{/etc/mediawiki/LocalSettings.php}}}:
    192193{{{
    193194wfLoadExtension( 'ParserFunctions' );
     
    208209== MediaWiki ==
    209210
    210  * edit /etc/mediawiki/LocalSettings.php as root. add the following lines:
     211 * edit {{{/etc/mediawiki/LocalSettings.php}}} as root. add the following lines:
    211212{{{
    212213$wgUsePrivateIPs = true;